about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e0cdfc4..21a50b0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,6 +13,13 @@ repository = "https://github.com/gennyble/colorsquash"
 rgb = "0.8.36"
 gifed = { path = "../gifed/gifed", optional = true }
 rand = { version = "0.8.5", optional = true }
+kmeans = { version = "0.2.1", optional = true }
+
+[features]
+default = ["simd-kmeans"]
+# use the kmeans crate instead of the internal kmeans implementation. the crate
+# is faster and uses SIMD but requries nightly Rust.
+simd-kmeans = ["kmeans"]
 
 [workspace]
 members = ["squash"]