about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgennyble <gen@nyble.dev>2024-01-16 15:06:29 -0600
committergennyble <gen@nyble.dev>2024-01-16 15:06:29 -0600
commitc887f5fef803e720052898b9561028dfd50e51db (patch)
tree0ea9c8c9e6c4603d0626bc12e653b6421f16f78a /Cargo.toml
parentbbbac45d835dd40c3fb53f8c7f9a2731783841e8 (diff)
downloadcolorsquash-c887f5fef803e720052898b9561028dfd50e51db.tar.gz
colorsquash-c887f5fef803e720052898b9561028dfd50e51db.zip
ability to choose kmeans implementation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e0cdfc4..21a50b0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,6 +13,13 @@ repository = "https://github.com/gennyble/colorsquash"
 rgb = "0.8.36"
 gifed = { path = "../gifed/gifed", optional = true }
 rand = { version = "0.8.5", optional = true }
+kmeans = { version = "0.2.1", optional = true }
+
+[features]
+default = ["simd-kmeans"]
+# use the kmeans crate instead of the internal kmeans implementation. the crate
+# is faster and uses SIMD but requries nightly Rust.
+simd-kmeans = ["kmeans"]
 
 [workspace]
 members = ["squash"]