about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fe0fe57..a1d0021 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,10 +10,16 @@ repository = "https://github.com/gennyble/whenwasit"
 camino = "1.1.6"
 getopts = "0.2.21"
 
+# takes ~250K off the binary
+[profile.release]
+strip = true
+codegen-units = 1
+panic = "abort"
+lto = true
+
 # The profile that 'cargo dist' will build with
 [profile.dist]
 inherits = "release"
-lto = "thin"
 
 # Config for 'cargo dist'
 [workspace.metadata.dist]