about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgennyble <gen@nyble.dev>2023-11-06 05:42:34 -0600
committergennyble <gen@nyble.dev>2023-11-06 05:42:34 -0600
commit665073d5cfe56a4ac2a6a3b8b6fa859506d85b1c (patch)
tree8b83f651adcfc17ab5129df59b65e74d0ecc83fe /Cargo.toml
parentf8cc0ae9ae030aca2887dc2a1f57f314181c0a58 (diff)
downloadwhenwasit-665073d5cfe56a4ac2a6a3b8b6fa859506d85b1c.tar.gz
whenwasit-665073d5cfe56a4ac2a6a3b8b6fa859506d85b1c.zip
cleanup
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 2 insertions, 22 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a1d0021..db794bd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,7 +2,7 @@
 name = "whenwasit"
 version = "0.1.0"
 edition = "2021"
-repository = "https://github.com/gennyble/whenwasit"
+repository = "https://git.nyble.dev/smalls/whenwasit"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
@@ -10,29 +10,9 @@ repository = "https://github.com/gennyble/whenwasit"
 camino = "1.1.6"
 getopts = "0.2.21"
 
-# takes ~250K off the binary
+# takes ~250K off the binary (tested on MacOS)
 [profile.release]
 strip = true
 codegen-units = 1
 panic = "abort"
 lto = true
-
-# The profile that 'cargo dist' will build with
-[profile.dist]
-inherits = "release"
-
-# Config for 'cargo dist'
-[workspace.metadata.dist]
-# The preferred cargo-dist version to use in CI (Cargo.toml SemVer syntax)
-cargo-dist-version = "0.1.0"
-# CI backends to support (see 'cargo dist generate-ci')
-ci = ["github"]
-# The installers to generate for each app
-installers = []
-# Target platforms to build apps for (Rust target-triple syntax)
-targets = [
-	"x86_64-unknown-linux-gnu",
-	"x86_64-apple-darwin",
-	"x86_64-pc-windows-msvc",
-	"aarch64-apple-darwin",
-]