about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgennyble <gen@nyble.dev>2023-08-25 18:48:39 -0500
committergennyble <gen@nyble.dev>2023-08-25 18:48:39 -0500
commit47cf62376f28b83c3e3514d6e4e111a55bac4304 (patch)
tree22ae313ca36d2c3be08d233960bbdfec8ee284dd /Cargo.toml
parent85052baf6ff0ce914ff44435cb8ba3edb8725947 (diff)
downloadwhenwasit-47cf62376f28b83c3e3514d6e4e111a55bac4304.tar.gz
whenwasit-47cf62376f28b83c3e3514d6e4e111a55bac4304.zip
cargo dist, release v0.1.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 351971e..fe0fe57 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,9 +2,31 @@
 name = "whenwasit"
 version = "0.1.0"
 edition = "2021"
+repository = "https://github.com/gennyble/whenwasit"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [dependencies]
 camino = "1.1.6"
 getopts = "0.2.21"
+
+# The profile that 'cargo dist' will build with
+[profile.dist]
+inherits = "release"
+lto = "thin"
+
+# Config for 'cargo dist'
+[workspace.metadata.dist]
+# The preferred cargo-dist version to use in CI (Cargo.toml SemVer syntax)
+cargo-dist-version = "0.1.0"
+# CI backends to support (see 'cargo dist generate-ci')
+ci = ["github"]
+# The installers to generate for each app
+installers = []
+# Target platforms to build apps for (Rust target-triple syntax)
+targets = [
+	"x86_64-unknown-linux-gnu",
+	"x86_64-apple-darwin",
+	"x86_64-pc-windows-msvc",
+	"aarch64-apple-darwin",
+]