about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgennyble <gen@nyble.dev>2023-11-06 00:11:09 -0600
committergennyble <gen@nyble.dev>2023-11-06 00:11:09 -0600
commite70327c824d145274430f5f315f464d1d3fda53d (patch)
tree4503f26ebdc7c2e5fd642f0ce1d13ae3418e2143 /Cargo.toml
downloadpopline-e70327c824d145274430f5f315f464d1d3fda53d.tar.gz
popline-e70327c824d145274430f5f315f464d1d3fda53d.zip
popline :)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..6d6c3fc
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "popline"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+# takes ~250K off the binary (tested on MacOS)
+[profile.release]
+strip = true
+codegen-units = 1
+panic = "abort"
+lto = true
+
+[dependencies]