about summary refs log tree commit diff
path: root/squash/Cargo.toml
diff options
context:
space:
mode:
authorgennyble <gen@nyble.dev>2023-10-09 01:27:19 -0500
committergennyble <gen@nyble.dev>2023-10-09 01:27:19 -0500
commite52599e25372827fd3cef1433773c5a1b181fd3e (patch)
treedefb472fdf74b3d6c163c0983f52e3454b5d0898 /squash/Cargo.toml
parent1575e5fd1a358a3c997288998d7b25f87472905d (diff)
downloadcolorsquash-e52599e25372827fd3cef1433773c5a1b181fd3e.tar.gz
colorsquash-e52599e25372827fd3cef1433773c5a1b181fd3e.zip
squash
Diffstat (limited to 'squash/Cargo.toml')
-rw-r--r--squash/Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/squash/Cargo.toml b/squash/Cargo.toml
index 18f2be3..16c450a 100644
--- a/squash/Cargo.toml
+++ b/squash/Cargo.toml
@@ -6,5 +6,10 @@ edition = "2021"
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [dependencies]
+colorsquash = { path = "..", version = "0.1.0" }
+anyhow = "1.0.75"
 camino = "1.1.6"
-png = "0.17.10"
+# time of writing:
+# png has a change to ignore extra iCCP blocks my test image needed. it hasn't
+# been released yet, so we're using the git here. the commit we require is e4b4811
+png = { git = "https://github.com/image-rs/image-png.git", rev = "f10238a1e886b228e7da5301e5c0f5011316f2d6" }