about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..5e4dd38
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "v4l16"
+version = "0.1.0"
+edition = "2021"
+#build = "build.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+#[dependencies]
+#v4l2-sys-mit = "0.3.0" #{ path = "libv4l-rs/v4l2-sys" }
+
+[target.'cfg(target_os = "linux")'.dependencies.nokhwa]
+version = "0.10.3"
+#path = "nokhwa"
+#git = "https://github.com/l1npengtul/nokhwa"
+# Use the native input backends, enable WGPU integration
+default-features = false
+features = ["input-v4l", "nokhwa-bindings-linux"]
+
+[target.'cfg(target_os = "macos")'.dependencies.nokhwa]
+version = "^0.10.0"
+features = ["input-native"]
+
+#[replace]
+#"v4l2-sys-mit:0.2.0" = { path = "libv4l-rs/v4l2-sys" }
+#"v4l:0.13.0" = { path = "libv4l-rs" }