about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgennyble <gen@nyble.dev>2024-10-11 21:54:58 -0500
committergennyble <gen@nyble.dev>2024-10-11 21:54:58 -0500
commitc2a15e4447d7535fc3b9f8fabcfacf26947a84d2 (patch)
tree4b566334c8e55518fdf5fb2b0af58eaf49b37d69 /Cargo.toml
parentb0f6242b8b936d47b32c227cab5b18b4902cf9c4 (diff)
downloadawake-c2a15e4447d7535fc3b9f8fabcfacf26947a84d2.tar.gz
awake-c2a15e4447d7535fc3b9f8fabcfacf26947a84d2.zip
truly i do not know what any of this is; git reinit
Diffstat (limited to 'Cargo.toml')
-rwxr-xr-x[-rw-r--r--]Cargo.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 685ff75..11acd42 100644..100755
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,9 @@ snafu = "0.8.0"
 bempline = { git = "https://github.com/gennyble/bempline" }
 tokio = { version = "1.36.0", features = ["full"] }
 tokio-util = { version = "0.7.10", features = ["io"] }
-confindent = { git = "https://github.com/gennyble/confindent" }
+confindent = { git = "https://github.com/gennyble/confindent", branch = "v3.0-writing", features = [
+	"macros",
+] }
 cutie = { path = "../cutie" }
 tracing = "0.1.40"
 tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }
@@ -24,3 +26,8 @@ time = { version = "0.3.36", features = [
 ] }
 sha2 = "0.10.8"
 url = "2.5.0"
+
+# for generating Atom URNs
+[dependencies.rand]
+version = "0.8.5"
+features = ["std", "std_rng"]